Jump to content
PortSIP PBX for Unified Communications

FenilS14

Members
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

0 Neutral

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi Joe, I tried calling the PortSIP_playAudioFileToRemote method inside onInviteAnswered or onInviteConnected events, but both these events gets executed quite a while before the user picks up. Can you suggest any other event which I might be missing out or any other workaround....? Thanks, Fenil
  2. Hi Joe, Oohh God !! This was the mistake I've been doing since long. Thanks a lot Joe. Appreciated!! Now, I'm able to play the audio file on the remote device. Thanks for your consistent support. But, I would like to ask for your little help again. I'm able to play the audio file on remote device , but the issue is I can play the audio file even when the remote user hasn't picked up the call. And when the user picks up , half of the audio file has been played. I've implemented the event onInviteAnswered() but I can observe that the program call goes to this method even when the user hasn't picked up and the audio file starts playing. Could you please suggest some work around here ? Thanks & Best Regards, Fenil Shah
  3. Hi Joe, I'm not using the SIP sample on both the sides. I'm trying to make the call from a server which I've created on my end & using this SIP I 'm calling a cell no. (Any Mobile Carrier) & not on SIP. When the other user(cell number) receives my call, I'm trying to play a .wav file. It is necessary to use the SIP on both sides in order to play the audio file ...? Thanks & Regards, Fenil
  4. Hi Joe, When I place the call through modem, I can hear the receiver's voice but the other person can't hear my voice. Moreover, When I run the sample code, it detects the speaker as "Remote Audio" but for Microphone it's blank. I even tried adjusting the volume for the microphone, but still the other person(called person) isn't able to hear my voice. Tha nks, Fenil
  5. Hi Joe, Thanks a Lot for the consistent help. I noticed that I'm able to play the waiting music(already uploaded to my modem configuration) while I try to hold the call. But when I choose the wav file and click the start button, the function call goes to _sdkLib.playAudioFileToRemote(_CallSessions[_CurrentlyLine].getSessionId(), waveFile, 16000, false); and it returns the code 0 (which means successful). But not able to hear the sound on remote. Is there any possibility that I might me using the older version of the DLL. So, could you please share me the DLL that you used and Also, another query that do I need to upload the wav file to my modem configuration or any such thing....? Thanks, Fenil
  6. Hi Joe, I've used the sample code provided at the given link : http://www.portsip.com/portsip-voip-sdk. I just get the code and execute with the configurations and stun server created on my end with the modem configurations. Please suggesst if I require to do anything else. or you can share me the sample code which you are using or any such sort of. Thanks, Fenil
  7. Hi Joe, Thanks for re-sending the link. but still when i visit the link it gives the error Page Not Found. Is there any restriction that the link gets deactivated in sometime...?
  8. Hi Admin, Still Not working Thanks, Fenil
  9. Hi Joe, I tried with the audio file format you suggested 8000/16000 /32000/48000Hz, 16 bit , pcm ,mono the file I used: https://www.dropbox.com/s/etxzed3e2c2j62i/sppech (1)_updated.wav?dl=0 Thanks, Fenil
  10. Hi Joe , Thanks for the help. BUt, couldn't find the wave file at above link. Could you please again share the wav file? Thanks, Fenil
  11. Hi Admin, I checked the format of my audio file. It's a Wave file. It plays perfectly when played with the Window Media Player. Also, when I call the method PlayAudioFileToRemote() it executes successfully as it returns 0. But, still the wave file is not heard over the call. Could you please suggest any workaround?
  12. Hi Admin, Could you please help me out here? Thanks, Fenil
  13. Also I get the error -70001 (EAudioChannelNotFound) from the PortSIP_playAudioFileToRemote method. Please help me out....
  14. Hi Admin, Thanks for the reply. The audio file which I'm using is the Wave file(.wav) which plays perfectly fine when played on Multimedia apps . Also the program call goes to the PortSIP_playAudioFileToRemote method. I'm unable to attach the wave file here.
  15. Hi I want to implement a IVRS like feature where in after the call is attended, I want to play a wav file. The call is successfully getting placed, but the audio file is not played. The application calls the method PortSIP_playAudioFileToRemote but the audio file is not being heard when the user recieves the call. Any help would be appreciated.
×
×
  • Create New...